Dice logo
Dice
Posted 44 days agoVerified live 13h ago

SDK Engineer

Brief overview

Remote
UndergradOr in progress
4+ yrsMinimum
C/C++Object-Oriented ProgrammingWiresharkMicrosoft Visual StudioValgrindFlame GraphTCP/UDP/TLS/RTP/SRTP/RCTPVoIP TechnologiesRFC2833/RFC3550/RFC5760SIP ProtocolPJSIPreSIProcateFreeSWITCH

About the company

Dice is the go-to career marketplace for tech professionals.

Job description

Summary

Zoom Communications develops collaboration and communication products, including Zoom Phone. The SDK Engineer will lead cross-platform development for the Zoom Phone SDK, designing features, ensuring reliability and stability, testing implementations, and supporting client, server, product management, and customer support teams.

Responsibilities

  • Design the overall architecture for Zoom Phone tasks and communicate interfaces with server and client teams. This includes detailed control flow at SIP level, specific command requests and responses between client, server, and UI layers
  • Implement new features and unit test cases according to new feature implementation. Drive tasks across teams and make sure roll out features follow the release plan
  • Conduct integration testing with server and client teams
  • Use Windows Performance Analyzer (WPA) or relevant tool, to prevent memory leaks in SDK code
  • Use Checkmarx to scan and fix SDK code issues
  • Use User-Mode Dump Heap (UMDH) to capture and analyze heap memory allocations for a process
  • Perform sanity testing to prevent crash and regression issues. Perform SDK API auto testing based on an internal tool
  • Maintain auto testing tools and improve those tools to support more automatic testing scenarios
  • Review customer tickets and work with support team, analyze control flow, SIP flow and determine root cause
  • Examine client problem report on demand, analyze call details, and perform root cause analysis
  • Review bugs with the reporter to understand bugs and reproduced steps, then perform root; cause analysis and determine a solution
  • Perform integration testing at the development branch and release branch to ensure the fix has no negative impact
  • Work closely with the product management team to define requirements, create user stories and collect use cases on new features
  • Collaborate with other engineering teams to confirm final design scope and assign task owners. Support client team with fire drill testing before rolling out new releases and check the production crash reports after new release roll-out
  • Work on enhancements for our automatic client report analysis tool
  • Track critical and important issues found in client problem reports

Skills

  • Requires a Bachelor's degree in Computer Science, Information Security, a related field, or a foreign degree equivalent
  • Requires 4 years of experience in the job offered or a related occupation
  • Requires 4 years experience in utilizing C/C++ and object-oriented programming in task design, fixing bugs, and implementing development work
  • Requires 4 years experience in utilizing Wireshark to analyze VOIP traffic calls in network programming
  • Requires 4 years experience in utilizing IDE tools including Microsoft Studio for debugging code
  • Requires 4 years experience in utilizing Valgrind to perform memory checks
  • Requires 4 years experience in utilizing Flame Graph to check CPU cost information and code enhancements
  • Requires 4 years experience in utilizing network protocols including TCP, UDP, TLS, RTP, SRTP, and RCTP in real-time traffic transmission and audio quality enhancements
  • Requires 4 years experience in utilizing VoIP technologies including RFC2833, RFC3550 and RFC 5760 in real time communication to control system traffic, control audio quality, and develop solutions to ensure quality user experience
  • Requires 4 years experience in utilizing open-source projects including SIP stacks (PJSIP, reSIProcate, FreeSWITCH) to support fundamental layer covering low-level SIP protocol parsing
  • Requires 4 years experience in utilizing integrated development environments (IDEs) including Visual Studio in software development
  • Position does not require U.S. or domestic travel

Qualifications

Must Haves

  • Requires a Bachelor's degree in Computer Science, Information Security, a related field, or a foreign degree equivalent
  • Requires 4 years of experience in the job offered or a related occupation
  • Requires 4 years experience in utilizing C/C++ and object-oriented programming in task design, fixing bugs, and implementing development work
  • Requires 4 years experience in utilizing Wireshark to analyze VOIP traffic calls in network programming
  • Requires 4 years experience in utilizing IDE tools including Microsoft Studio for debugging code
  • Requires 4 years experience in utilizing Valgrind to perform memory checks
  • Requires 4 years experience in utilizing Flame Graph to check CPU cost information and code enhancements
  • Requires 4 years experience in utilizing network protocols including TCP, UDP, TLS, RTP, SRTP, and RCTP in real-time traffic transmission and audio quality enhancements
  • Requires 4 years experience in utilizing VoIP technologies including RFC2833, RFC3550 and RFC 5760 in real time communication to control system traffic, control audio quality, and develop solutions to ensure quality user experience
  • Requires 4 years experience in utilizing open-source projects including SIP stacks (PJSIP, reSIProcate, FreeSWITCH) to support fundamental layer covering low-level SIP protocol parsing
  • Requires 4 years experience in utilizing integrated development environments (IDEs) including Visual Studio in software development
  • Position does not require U.S. or domestic travel

Benefits

  • Telecommuting work arrangement permitted.

More jobs like this